Articles in this Category

Top Left Text cha

Website Development Services

When you try to create a virtual device in the AVD manager (in Android Studio), most are x86 devices.  And you get a big red message that says, "HAXM is required for running x86 System Images".  And there's a link for HAXM installatio instructions.  In the instructions, it says, "The software requires an Intel CPU with Virtualization Technology (VT) support and one of the following operating systems...".

And even if you try to create a virtual device that's not x86, it still says that HAXM is recommended.

I tried ignoring it and going with the instructions from android.com (which have no mention of HAXM).  I get the following errors/info in Android Studio:

emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!


So I went back and created a new device in which the ABI is 'armeabi-v7a' (where it says HAXM is recommended - instead of required).... no errors!  But that still sucks.  Guess you're very limited on virtual devices on a computer that uses an AMD processor.
Comment (0) Hits: 893
X