Top Left Text cha

Website Development Services

I do not recommend updating to Joomla 3.5.

I updated the first of many sites to 3.5 today and immediately ran into bugs.  First, an error with updating it via the control panel (joomla update An error has occurred.  1242 Subquery returns more than 1 row).  Supposedly you're supposed to go to 'extensions' > 'database' > 'fix database'.  But you're supposed to go there before... how are you supposed to know there is going to be an issue?  Guess you're supposed to be psychic.  UPDATE: That is not a fix, actually.  There will not be a fix until 3.5.1.  So just don't upgrade yet.

Then, I logged into the site on the front end... logged out and get:
joomla 0 - Failed to start the session: already started by PHP.

I found a post on it already at https://issues.joomla.org/tracker/joomla-cms/9170

Apparently there's a long list of issues and some very complex ways to fix them. I'm not going through that. I will use the backup I made before upgrading and go back to Joomla 3.4.8.

I consider Joomla the #1 CMS.  But I don't have a lot of compliments for the developers when they release bug-ridden code to the general public as an official release. 

I swear this happens with every major update.  It happened with 3.4.  After seeing the destruction it caused, I decided to wait until 3.4.1 before upgrading my other sites.  I'll do the same here and wait until 3.5.1 or 3.5.2.

Add comment


Security code
Refresh

  • Guest - sarapaul

    Great step you have define it is really helpful for all developer

  • Guest - Segun

    I wish I saw this earlier. Unfortunately I updated without backup. Can you help with ideas to solve the problem? I keep getting this error:
    An error has occurred.
    0 Failed to start the session: already started by PHP ($_SESSION is set).

  • I can give you a possible solution, Segun. I'm working a 14 hour day for the second day in a row trying to finish a project before tomorrow. But I can help more tomorrow if you want.

    In the meantime, this might be an option for you. If you have Installatron, Fantastico, or a similar software manager in your hosting account (cPanel), you might try importing it into the software manager (if you didn't create it there and it's not already in the software manager). At that point, it should say there's an update (3.6.0 or 3.6.1). Then you can click update. I've fixed sites like that before. But... just in case that actually makes matters worse, I would create a file system and database backup before doing that. Also, check your version of PHP in the cPanel and make sure it's set to the Joomla 3.x version recommended requirements.

    Good luck! Just let me know if that didn't work and you need more help tomorrow.

  • The issue seems to be fixed in version 3.5.1.

Leave your comments

Post comment as a guest

0
Your comments are subjected to administrator's moderation.
X